Stripe recurring subscription not registering in Membership Pro

  • Candice Venter
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
2 months 1 week ago - 2 months 1 week ago #121087 by Candice Venter
Hi there,

We have had Stripe being used for our recurring memberships (and for new memberships who join with a trial period) since June. In September, this stopped processing the renewal on the Membership Pro side. Everything is processing as it should in Stripe - the payments are being taken successfully, but Membership Pro is expiring the memberships which suggests there is an issue with communication between the 2, and we have to manually activate the membership in Membership Pro.

I have refreshed API's and webhooks, and tried looking into this as much as possible and technically everything seems to be where it should be, but the problem persists. Membership Pro is not creating the logs for itself either.

The only place I could see this could potentially be falling over is that the webhook is in the wrong place? Should it be "Endpoints receiving events from your account" or "Endpoints receiving events from Connect applications"?

Has anyone had a similar experience? How did you fix it?

We are launching monthly recurring memberships next week and this is urgent to get fixed before it becomes an admin nightmare. Any help would be greatly appreciated.

Many Thanks,
Candice
Last edit: 2 months 1 week ago by Candice Venter.

Please Log in or Create an account to join the conversation.

  • Tuan Pham Ngoc
  • Away
  • Administrator
  • Administrator
More
2 months 1 week ago #121090 by Tuan Pham Ngoc
Hello Candice

I guess it's something wrong with webhook configuration. You should use Endpoints receiving events from your account, not from Connect applications

Also, in the webhook settings, choose All Events to be safe

Check and make sure webhook URL is correct, too

Tuan

Please Log in or Create an account to join the conversation.