A few issues

  • Jeff Stone
  • Jeff Stone's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
1 week 2 days ago #117185 by Jeff Stone
A few issues was created by Jeff Stone
Hi there, just updated to the 2.6.2 version from 2.5.4 and noticed even before updating that there were a few issues...
  1. venue_name field missing from the _app_sch_venues table - had to manually add it
  2. SMS Setting does not save after making changes through the admin section
So far, that's all I've found. The issues are still there even after updating to 2.6.2 and then running Fix Database Schema.
I'm just setting up and testing right now, so not sure if I shouild completely unistall the package, and re-install the 2.6.2 version from scratch?

Feature request:
It would be nice to have a venue based fee, flat rate that would be added in addition to the service hourly rate... I am a photographer, and need to add a flat rate location fee that would be added to the regular hourly service rate. I would essentially have 2 venues: 1 would be a studio with no extra fee, and 2 would be an on location fee, which would be an additional flat rate fee added to the hourly rate.

Thanks,

Jeff

Please Log in or Create an account to join the conversation.

More
1 week 1 day ago #117194 by Mr. Dam
Replied by Mr. Dam on topic A few issues
Hi Jeff,
2 issues you mentioned in forum topic is solved in OS Services Booking 2.6.3. Please upgrade component to get resolved issues
Thanks
Dam

Please Log in or Create an account to join the conversation.

  • Jeff Stone
  • Jeff Stone's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
1 week 1 day ago - 1 week 1 day ago #117237 by Jeff Stone
Replied by Jeff Stone on topic A few issues
Thanks Dam,

I will update and check out the results!

I have noticed that in many cases, with 2 employees, only one employee will show for a service, also, if I have 2 venues, only 1 is showing for each service: venue 1 will only show on service 1, and venue 2 will only show on service 2, and each service only shows 1 employee...

What do you think of having venue based flat rate fees as mentioned above?

The idea is that you could assign a fee that is independent of hourly rate - for example, as a photographer, sometimes I shoot at various locations which require an additional fee... so I might shoot 2 and half hours at an on-location shoot at $50 an hour plus an additional $50 flat rate fee for location for a total of $125 + additional $50 = $175...

Jeff
Last edit: 1 week 1 day ago by Jeff Stone. Reason: additional information added

Please Log in or Create an account to join the conversation.

More
1 week 11 hours ago #117255 by Mr. Dam
Replied by Mr. Dam on topic A few issues
Hi Jeff,
OS Services Booking has feature to setup additional cost for employees based on hours in specific dates. I am not sure that you can use this feature for your Booking system?
Thanks
Dam

Please Log in or Create an account to join the conversation.

More
1 week 11 hours ago #117256 by Mr. Dam
Replied by Mr. Dam on topic A few issues
Here is the part that you can enter Custom Additional cost for employees.

Thanks
Dam
Attachments:

Please Log in or Create an account to join the conversation.

  • Jeff Stone
  • Jeff Stone's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
1 week 4 hours ago - 1 week 4 hours ago #117282 by Jeff Stone
Replied by Jeff Stone on topic A few issues
Hi Dam,

Yes, I already discovered that. What I am talking about is the ability to add a cost to a venue, additional to the service cost and employee additional cost... see attached screen shot


Also, with 2 employees, still only having one employee tab showing - dates that have one employee not working will show the other employee if they are working that date - it will show a tab for the one employee when there should be two available for that particular day, and no tab if only one employee is working that day. And I have Employee can work in multiple services in the same time enabled.

Thanks,

Jeff
Attachments:
Last edit: 1 week 4 hours ago by Jeff Stone. Reason: added screen shot

Please Log in or Create an account to join the conversation.

  • Jeff Stone
  • Jeff Stone's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
6 days 22 hours ago #117294 by Jeff Stone
Replied by Jeff Stone on topic A few issues
Should also mention that the check-out page breaks the template layout, moving the right side sidebar to below the check-out page... Using Rockettheme's latest version of Denali template with the latest version of Gantry 5, and Joomla 3.8.12, PHP 7.0.31

Thinking maybe I need to uninstall the OSB package, component, modules, plugins and clean out the DB tables, and reinstall the latest version of OSB?

Please Log in or Create an account to join the conversation.

  • Jeff Stone
  • Jeff Stone's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
6 days 20 hours ago - 6 days 19 hours ago #117299 by Jeff Stone
Replied by Jeff Stone on topic A few issues
So, I just tried a fresh install of 2.6.3 on another Joomla 3.8.12 site running another Rockettheme Gantry 5 template, and the same issue, when it goes to the checkout page, the sidebar area is still there, but the content moves to below the checkout page...

Also, when clicking on the checkout button the from the cart box on the left side, it returns an error 404 page not found, go back, and click the checkout button from the cart box, it works... another issue is the Bootstrap 3 and 4 dropdown selector in the general configuration tab also messes with the template layout - only one that works is Bootstrap 2.

One more thing, when creating coupons, I don't see an area to enter a coupon during the checkout stage...
^^ My bad, had the date for coupon set to start next month - explains why it wasn't showing area for coupon ^^

Ideas?
Last edit: 6 days 19 hours ago by Jeff Stone. Reason: additional information added

Please Log in or Create an account to join the conversation.

  • Jeff Stone
  • Jeff Stone's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
6 days 18 hours ago #117300 by Jeff Stone
Replied by Jeff Stone on topic A few issues
Not sure what I did, may have been enabling "Load Bootstrap Twitter" with Bootstrap 2 loaded, but I now have both employees tabs showing.

Okay, another small detail I noticed, is with the add to waiting list... if I am on today's date, and all my available booking times have now expired, for example, my last time slot is 8:00pm to 9:00pm and it is now 9:14pm, all the time slots are red, (time has passed) but has the add to waiting list option showing... this should not be, because we are now past these time slots. This should only work for time slots booked in the future, not in the past...

Sorry to be posting so often, but I am in the testing stages and want to make sure everything is working as expected before I make to extension live for customers. I will probably post more as I find other issues...

Please Log in or Create an account to join the conversation.

More
6 days 15 hours ago #117308 by Mr. Dam
Replied by Mr. Dam on topic A few issues
Hi Jeff,
I see you have some troubles with OS Services Booking, i think you can add my Skype name: thucdam84 and we will discuss more details about them.
Thanks
Dam

Please Log in or Create an account to join the conversation.

Moderators: Mr. Dam