EShop 2.5.5 - Fully compatible Joomla! 3.7 & PHP 7

  • Giang Dinh Truong
  • Giang Dinh Truong's Avatar Topic Author
  • Offline
  • Administrator
  • Administrator
More
2 years 1 month ago - 2 years 1 month ago #98678 by Giang Dinh Truong
EShop 2.5.5 - Fully compatible Joomla! 3.7 & PHP 7 was created by Giang Dinh Truong
Dear customers

Today, I am happy to announce the next release of EShop Shopping Cart extension, version 2.5.5. This is an important release according to the release of Joomla 3.7.

1. Fully compatible with latest Joomla 3.7.x

There were some minor compatible issues found on Joomla 3.7.x, we resolved them so EShop 2.5.5 is fully compatible with latest Joomla 3.7.x and PHP 7 now.

So if you are using EShop on the Joomla 3.7, please upgrade EShop to the latest version 2.5.5 NOW!



2. Add more Payment Plugins

- Cybersource payment plugin: eshopdocs.joomservices.com/plugins-and-t...-plugins/cybersource

- Squareup payment plugin: eshopdocs.joomservices.com/plugins-and-t...ent-plugins/squareup

- Beanstream payment plugin: eshopdocs.joomservices.com/plugins-and-t...t-plugins/beanstream

- Add copies of offline payment plugins package (From offline 1 to offline 6). Read more about it here: eshopdocs.joomservices.com/plugins-and-t...ment-plugins/offline

3. Other new features/improvements

- Add configuration for Email a Friend function.

- Add the Availability column to Products Table Layout.

- Add the table layout for products filter.

- Backup and restore fields.xml file when installing EShop.

- PayPal Email Receiver validation small fix.

- Exports Order Enhancement.

- Fix small issue with Product Image link when sharing on Facebook.

- Fix the search to show products in all category levels.

- Fix bug on EShop Configuration.

- Fix bug with Show Price based on Option.

- Convert amount to correct activated currency to send to payment gateways.

- Invoice is only available for completed orders.

- Fix bug in Virtuemart Migrate tool.

- Fix issue with Customers view at back-end side.

- CSS Enhancements.

Thanks for continue using EShop and our support services. We will continue working hard to make it better from time to time.

Sincerely, Giang
Last edit: 2 years 1 month ago by Giang Dinh Truong.
The following user(s) said Thank You: Chris Lewis, Cat Gio, Davide, Danijel Grozdek, Jorge, howard clark

Please Log in or Create an account to join the conversation.

  • Danijel Grozdek
  • Offline
  • Junior Boarder
  • Junior Boarder
More
2 years 1 month ago #98718 by Danijel Grozdek
Replied by Danijel Grozdek on topic EShop 2.5.5 - Fully compatible Joomla! 3.7 & PHP 7
Thank you for improvements.
I'm still waiting for dynamic SKU and Availability on products page to be implemented.

Please Log in or Create an account to join the conversation.

  • Giang Dinh Truong
  • Giang Dinh Truong's Avatar Topic Author
  • Offline
  • Administrator
  • Administrator
More
2 years 3 weeks ago #99515 by Giang Dinh Truong
Replied by Giang Dinh Truong on topic EShop 2.5.5 - Fully compatible Joomla! 3.7 & PHP 7
OK Danijel!

This is not ready in this version yet!

Sincerely, Giang

Please Log in or Create an account to join the conversation.

  • Danijel Grozdek
  • Offline
  • Junior Boarder
  • Junior Boarder
More
2 years 3 weeks ago #99518 by Danijel Grozdek
Replied by Danijel Grozdek on topic EShop 2.5.5 - Fully compatible Joomla! 3.7 & PHP 7
Awesome, good to see you're considering this feature!

Please Log in or Create an account to join the conversation.

  • Giang Dinh Truong
  • Giang Dinh Truong's Avatar Topic Author
  • Offline
  • Administrator
  • Administrator
More
2 years 3 weeks ago #99522 by Giang Dinh Truong
Replied by Giang Dinh Truong on topic EShop 2.5.5 - Fully compatible Joomla! 3.7 & PHP 7
OK Danijel!

Please Log in or Create an account to join the conversation.

  • Lynne Carlton-Bynder
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 year 10 months ago #101567 by Lynne Carlton-Bynder
Replied by Lynne Carlton-Bynder on topic EShop 2.5.5 - Fully compatible Joomla! 3.7 & PHP 7
Is eShop 2.5.5 compatible with Joomla 3.7.4 released on July 25, 2017?

Please Log in or Create an account to join the conversation.

  • Giang Dinh Truong
  • Giang Dinh Truong's Avatar Topic Author
  • Offline
  • Administrator
  • Administrator
More
1 year 10 months ago #101668 by Giang Dinh Truong
Replied by Giang Dinh Truong on topic EShop 2.5.5 - Fully compatible Joomla! 3.7 & PHP 7
Hello Linne,

Yes of course, it is compatible with latest Joomla 3.7.4 too. You should also upgrade EShop to the latest version 2.6.0 of EShop which was just released yesterday 01 August 1027: www.joomdonation.com/forum/released-vers...-2-6-0-released.html

Sincerely, Giang

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #108575 by howard clark
Replied by howard clark on topic EShop 2.5.5 - Fully compatible Joomla! 3.7 & PHP 7
Why is it that taking I am running Joomla 3.8.3 and PHP 5.6.30 eshop works fine. I I then enable PHP 7 using my cPanel and eshop stops working properly, like I cannot get into products or system configuration and a few other things in the back end?
This is taking that you say version 3.7 & PHP7 is compatible and therefore 3.8.3 & PHP7 should also be? From my point of view it is not?
Am I missing something????

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #108576 by howard clark
Replied by howard clark on topic EShop 2.5.5 - Fully compatible Joomla! 3.7 & PHP 7
Forgot to mention that Eshop version is 2.8.1

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #108577 by Paul T
Hi Howard,
I am running
PHP Version 7.1.4
Joomla! 3.8.3
EShop version 2.8.1
and it all runs fine, so I would say it is more likely to be something on your end playing up. I have found that clearing the site cache and your browser cache often helps when swapping things over. Have you tried that?
Paul

Please Log in or Create an account to join the conversation.

Moderators: Giang Dinh Truong