Tool Bar buttons in Registrant Manager screen not working

  • James Riley
  • James Riley's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
More
2 weeks 18 hours ago - 2 weeks 18 hours ago #124160 by James Riley
I've run into an odd bug on my site: many of the the top-row Tool Bar buttons in the Registrant Manager either:

1) sends me to my site's homepage with an error message about not having permission to do that task (sample message: Error: You are not allowed to export registrants! Please contact site administrator). I'm logged in as a superuser, so I don't know why it's not granting me permission!!; or
2) presenting me with a "The most recent request was denied because it had an invalid security token. Please refresh the page and try again" backend error message.

Is any one else having issues with the Registrant Manager?

An example of #1 above, clicking the Export toolbar button. I can still use the "Export Registrant" button on the EB Dashboard without error!

In the video, you can ever-so-briefly see the error message appear before my header photo forces it off screen.

James Riley .: EventBooking user since 2014 :.
.: grfx & web design / IT / AV @ St. Therese Institute of Faith and Mission, Bruno, SK, Canada :.
Attachments:
Last edit: 2 weeks 18 hours ago by James Riley. Reason: add more info

Please Log in or Create an account to join the conversation.

More
2 weeks 10 hours ago #124164 by Tuan Pham Ngoc
Hello James

I would say that you are having permission problem on the site for some reasons:

1. When you press Export, you are being logged out and that's why the permission checking does not work?

2. The error usually related to session (it's a Joomla core API method to check the token, so it should work well)

So I guess there is something special on your site. Do you use service such as cloudfare? If so, maybe try to disable it

Or try to use a different browser?

Tuan

Please Log in or Create an account to join the conversation.

  • James Riley
  • James Riley's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
More
1 week 6 days ago #124184 by James Riley
Thanks for your suggestions, Tuan.

After a few of hours of trying different CloudFlare settings, different browsers, different users, logging-in on both front- and back-end (which worked for the Export problem), I finally remembered that I had a Template Override setup for that page!

I removed my override file and everything works again... :whistle:

James Riley .: EventBooking user since 2014 :.
.: grfx & web design / IT / AV @ St. Therese Institute of Faith and Mission, Bruno, SK, Canada :.

Please Log in or Create an account to join the conversation.

More
1 week 6 days ago #124185 by Tuan Pham Ngoc
Great. Thanks James for the update. Happy to hear that it is not a problem with Events Booking itself :)

Tuan

Please Log in or Create an account to join the conversation.

Moderators: Tuan Pham Ngoc